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Introduction to D-Lite

D-Lite is a software program that allows you to easily manage an IntelliProx cardholder 
database. The program provides you with a user-friendly interface for card management, 
using a spreadsheet format (such as Microsoft Excel). An extensive online help file places 
assistance at your fingertips. Communication between the D-Lite program and the IntelliProx 
unit is done through a serial connection made directly between the IntelliProx and an open 
serial port on the host computer. The D-Lite program can handle up to 500 cards per 
IntelliProx unit and can handle a virtually unlimited number of IntelliProx units.

D-Lite is a fully functional Windows program, making full use of all popular Windows 
features such as resizing and relocating windows, drag-and-drop functions, multiple windows 
open simultaneously, background operation, and "real-time" operation. D-Lite operates under 
Windows 95, Windows 98, and Windows NT.

NOTE: Use caution if using the HPP-22 to program IntelliProx units in conjunction with the 
D-Lite Cardholder Database Management Software. Both the HPP-22 and D-Lite are able to 
enroll cardholders into IntelliProx units. This means it is possible to have the cardholder D-
Lite file for an IntelliProx unit become out of sync with the cardholder file in the IntelliProx 
unit if the HPP-22 is used to program new cards. It is possible to synchronize the two sets of 
cardholder files by using the merge function in the D-Lite software. Please refer to the section 
on merging cardholder databases later in this Users Guide.

System Requirements
For proper operation of the D-Lite program the host computer operating the software must 
meet the following requirements.

• PC compatible computer using a Pentium-90 or faster microprocessor
• minimum of 16 MB of system RAM
• SVGA color monitor with SVGA graphics card (800 x 600 minimum resolution)
• CD-ROM
• keyboard
• mouse or other pointing device
• 5 MB of hard disk space
• a free COM port with a 16550 UART to support a direct RS-232 serial connection
• one of the following operating systems:

Windows 95™
Windows 98™
Windows NT™

COMTEST
The COMTEST program is a simple program. It is designed to send a string of characters out 
the host computer's COM port output and see if they are received back at the host computer's 
COM port input. It is not designed to determine if the COM port has more serious problems 
such as conflicts with other devices on the host computer. For these types of problems, 
troubleshooting by a computer technician is required. Instructions for using the COMTEST 
program are provided in the COMTEST Quick Start Guide document (P/N 01845-001) found 
in the \docs folder on the D-Lite CD-ROM.
01869-001 June 1999
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Software Installation
An InstallShield wizard handles the software installation process. To accommodate the 
installation process, the host computer must have at least 5 MB of free hard disk space, and it 
must have an SVGA color monitor with an SVGA graphics card set at a minimum resolution 
of 800 x 600 pixels.

There are three ways to install the program: using the Run command from the  button 
on the Windows desktop, using the Windows Explorer program, or using the Add/Remove 
Programs icon in the Windows Control Panel. Place the CD-ROM into the CD-ROM drive 
and use the method with which you are most comfortable.

Installing with the Run Command

1. Click on the  button on the Windows desktop.
2. Scroll through the list of Start menu options and click on the Run command (see Figure 

1-1).

Figure 1-1 – Software Installation Using the Run Command

3. Click on the  button. Navigate through the list of disk volumes and folders and 
locate the "Setup.exe" program on the installation CD-ROM.

4. Click on the "Setup.exe" program. "Setup.exe" appears in the Open field in the Run 
window (see Figure 1-1).

5. Click on the  button. The installation program begins. Skip to the Installation 
Wizard section below.
June 1999 01869-001
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Installing from Windows Explorer
1. Start the Windows Explorer program.
2. Navigate through the list of disk volumes and folders and locate the "Setup.exe" program 

on the installation CD-ROM (see Figure 1-2).

Figure 1-2 – Software Installation from the Windows Explorer Program

3. Double-click on the "Setup.exe" program and the installation program begins. Skip to the 
Installation Wizard section below.

Installing Using the Add/Remove Programs Feature

1. Click on the  button on the Windows desktop.
2. Scroll through the list of Start menu options and click on Settings → Control Panel. The 

Control Panel window, with a number of system icons, appears.

3. Locate and double-click on the  icon. An Add/Remove Programs Properties 
window appears.

4. Click on the  button in the top half of this window.
5. An Install Program from Floppy Disk or CD-ROM window appears. Click on the 

 button.
6. The Install Program from Floppy Disk or CD-ROM program automatically locates and 

starts the installation program on the D-Lite CD-ROM – skip to the Installation Wizard 
section below.
01869-001 June 1999
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Installation Wizard
Once the installation wizard begins simply follow the instructions displayed in the installation 
windows. 

After the Welcome and Software License windows are displayed, you are given the option of 
viewing the Readme.txt file. This file has the release notes for the D-Lite release and has other 
information regarding the D-Lite software. Please take a moment and review this file.

After reviewing the Readme.txt file, the Choose Installation Type window appears (see Figure 
1-3). This window gives you the option of installing the Demonstration version of the 
program or the Operating version of the program.

Figure 3 – Installation Type

After selecting the installation type a window is displayed reviewing the selected installation 
options. Finally, the installation begins. Once complete, a shortcut is placed on the 

Windows™ desktop. Double-click on this shortcut ( ) and the D-Lite program begins.

Uninstalling the Program
The easiest way to uninstall the D-Lite program is to run the uninstall script saved in the D-
Lite directory. This is done using Windows™ Explorer.

1. Start the Windows™ Explorer program.
2. Navigate through the list of disk volumes and folders and locate the "Uninst.isu" program 
in the D-Lite folder.
3. Double-click on the "Uninst.isu" program and follow the instructions. When complete, the 
program is uninstalled. This means the program is erased from the hard disk. Once this 
process starts, it cannot be reversed.
June 1999 01869-001
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Starting D-Lite

To start the program, simply double-click on the  shortcut on the Windows™ 
desktop. A D-Lite splash-screen is briefly displayed followed by the D-Lite program.

Figure 2-1 – D-Lite Splash-Screen

Logon
Once the program begins it prompts you for a password (see Figure 2-2). 

Figure 2-2 – Logon Window

Click in the Password field and enter the password (the factory default password is "keri"). 
For every character you type, an asterisk is entered in the Password field. This is done so that 
if someone is looking over your shoulder, this person cannot learn your password. Once you 

enter the password, click on the  button to enter the program.

NOTE: Keri Systems strongly recommends changing the password as soon as you can. This 
prevents someone who knows the default password from having access to the D-Lite program. 
Instructions for changing the password are found in the Unit Commands section later in this 
document.
01869-001 June 1999
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Figure 2-3 – The D-Lite Program Window

Configuration
Before operating the program, D-Lite must be configured for proper operation. There are four 
configuration options to be set.

• the Spreadsheet Font
• the Password
• the COM port
• the PC Personal Identification Number (PIN)

Set the Spreadsheet Font
Use the spreadsheet font to set the font, font size, and font style displayed on the spreadsheet 
window and printed.

NOTE: The System font is set as the Windows™ default font. However, for some printers, the 
System font automatically prints at 4 point size making a spreadsheet printout difficult to 
read. For ease of printing and screen formatting, Keri Systems recommends setting the 
spreadsheet font to a commonly used font (such as Arial, Helvetica, or Times New Roman) at 
a commonly printed size (such as 8, 10, or 12). The use of unique script fonts or large font 
sizes makes it difficult for the D-Lite program to setup its columns for viewing and printing.

1. To configure the spreadsheet printing font, click on the File → Spreadsheet Font pull-
down menu option. The following window appears.
June 1999 01869-001
Page 10 Revision 1.0



Keri Systems, Inc. D-Lite™ Users Guide
Figure 2-4 – The Spreadsheet Font Window

2. Scroll through the list of available fonts and click on the desired font.
3. Scroll through the list of available font styles and click on the desired style.
4. Scroll through the list of available font sizes and click on the desired size.
5. A sample of the selected font is displayed in the Sample field in the font window.

6. If the selected font is acceptable, click on the  button.
7. To exit the spreadsheet font window without implementing a change, click on the 

 button.

Set the Password
The password prevents just anyone from entering the D-Lite program and changing card/
cardholder entries. When starting the D-Lite program, you must enter the correct password in 
the Logon window to start the program.

1. To configure the password, click on the System → Set Configuration pull-down menu 
option. The following window appears.

Figure 2-5 – Set the Password
01869-001 June 1999
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2. Double-click in the Password field (see Figure 2-5). The asterisks in the field should all 
be highlighted.

3. Type the password you wish to use. The characters that you type appear in the Password 
field as asterisks. This is to prevent some one from looking over your shoulder as you 
type and learning your password.

4. Double-click in the Retype Password field (see Figure 2-5). The asterisks in the field 
should all be highlighted.

5. Again type the password you wish to use. This is done to verify the password you have 
selected has been entered correctly. The characters entered in both the Password and 
Retype Password fields must match for the password change to be accepted.

6. Click on the  button to accept the change.
7. To exit the system configuration window without implementing a change, click on the 

 button.

NOTE: Keri Systems strongly recommends changing from the default password of "keri" to a 
unique password to ensure that no one who knows the default password can access the 
IntelliProx unit.

NOTE: The password is case-insensitive; that means “KERI,” “KeRi,” and “keri” are 
equivalent passwords.

Set the COM Port
The COM port is the port through which all communication between D-Lite and the 
IntelliProx unit is done. It is critically important that the correct COM port value is entered. If 
the correct value is not entered, the D-Lite program cannot communicate with the IntelliProx 
unit.

1. To configure the COM port, click on the System → Set Configuration pull-down menu 
option. The window in Figure 2-5 appears.

2. Click on the  radio button corresponding to the COM port used for serial 
communication with the IntelliProx unit.

3. Click on the  button to accept the change.
4. To exit the system configuration window without implementing a change, click on the 

 button.

Set the PINs
There are two PINs (Personal Identification Numbers) used by the D-Lite program and the 
IntelliProx unit. The PC PIN identifies the host computer on which a cardholder file was 
created. The IntelliProx Unit PIN identifies the IntelliProx unit to which the cardholder file is 
being sent.

Whenever a cardholder file is downloaded from D-Lite to an IntelliProx unit, the IntelliProx 
compares the PC PIN stored in the cardholder file with the PIN set in the IntelliProx's 
memory and it compares the IntelliProx Unit PIN with the PIN set in the IntelliProx's 
memory. If the two sets of PINs match, the file is accepted, overwriting the data in the 
IntelliProx. If either of the two PINs do not match, the file is rejected.
June 1999 01869-001
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Conversely, whenever a cardholder file is uploaded from an IntelliProx unit to D-Lite, the D-
Lite program compares the PC PIN stored in the cardholder file with the PIN set in D-Lite's 
memory and it compares the IntelliProx Unit PIN with the PIN set in D-Lite's memory. If the 
two sets of PINs match, the file is accepted, overwriting the data in the D-Lite spreadsheet. If 
either of the two PINs do not match, the file is rejected.

Set the PC PIN
1. To configure the PC PIN, click on the System → Set Configuration pull-down menu 

option. The window in Figure 2-5 appears.
2. Double-click in the PC PIN field. The existing number is highlighted.
3. Enter the desired PIN. This PIN can be any number between 0 and 9999.

Figure 2-6 – New PC PIN

4. Click on the  button to accept the PC PIN entry.

NOTE: This command changes the PC PIN for a given cardholder database file, but does not 
send that PC PIN to the IntelliProx unit. Perform the following steps to send the PC PIN to 
the IntelliProx unit.
01869-001 June 1999
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Send the PC PIN to the IntelliProx Unit

1. Click on the System → Unit Commands pull-down menu option. The following window 
appears.

Figure 2-7 – Set PC and IntelliProx Unit PINs

2. Double-click in the Previous PC PIN field. The number is highlighted.
3. Enter the existing PC PIN.

4. Click on the  button. The new PC PIN is sent to the IntelliProx unit. From 
this point on, a cardholder data file that is sent to the IntelliProx unit must have this new 
PC PIN number or the file will be rejected by the IntelliProx unit.

NOTE: Keri Systems strongly recommends changing the PC PIN from the default value of 0 
to a unique number. This ensures that no one who knows the default PC PIN value can edit 
and send a cardholder file to an IntelliProx unit.

Set the IntelliProx Unit PIN
Perform the following steps to set the IntelliProx Unit PIN.

1. Click on the System → Unit Commands pull-down menu option. The window in Figure 
2-7 appears.

2. Double-click in the New Unit PIN field. The number is highlighted.
3. Enter the number to which you want to change. This PIN can be any number between 0 

and 9999.

4. Click on the  button. The new Unit PIN is sent to the IntelliProx unit. From 
this point on, a cardholder data file that is sent to the IntelliProx unit must have this new 
Unit PIN number or the file will be rejected by the IntelliProx unit.

NOTE: Keri Systems strongly recommends changing the IntelliProx Unit PIN from the default 
value of 1234 to a unique number. This ensures that no one who knows the default IntelliProx 
Unit PIN value can edit and send a cardholder file to an IntelliProx unit.
June 1999 01869-001
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Managing Cardholder/IntelliProx Databases
There are four ways to create, edit, and maintain cardholder databases.

1. Create a new cardholder database file and download the file to an IntelliProx.
2. Open and edit a stored database file and download the file to an IntelliProx.
3. Upload an existing IntelliProx database to the D-Lite program and save the information 

in a cardholder file.
4. Merge an existing cardholder database file with an uploaded IntelliProx database to 

create a combined database file.

Skip to the section that best describes your purpose for information on how to create, edit, and 
maintain a cardholder database.

Create a New Cardholder Database File and Download the File to an IntelliProx Unit
The instructions in this section explain how to create a new cardholder database file and then 
download that file to an IntelliProx unit. This is done with the following steps.

• create a new cardholder database file
• learn new cards (card enrollment)
• enter cardholder data
• save the new cardholder database file
• download the new cardholder database to an IntelliProx unit

Create a New File
Use the Create a New Card File command to clear all entries in the cardholder spreadsheet 
and to prepare the spreadsheet for the creation of a new cardholder file.

1. Click on the  button or use the File → New pull-down menu command. All data in 
the spreadsheet is cleared and the spreadsheet displays a blank form. The IntelliProx PIN 
is returned to the default value 1234.

NOTE: The PC PIN does not return to the default value of 0, but remains at the value set by 
the Set Configuration command.

NOTE: If changes have been made to an existing cardholder file displayed in the spreadsheet 
when the New command is performed, a warning window appears giving you the opportunity 
to save those changes before clearing the existing cardholder file.

Learn Mode
Use the Learn Mode commands to teach the cardholder database file which cards to accept.

Start Learn Mode

1. To start Learn Mode, click on the  button or use the System → Start Learn Mode 
pull-down menu command. When the reader switches to enrollment mode, the reader's 
LED changes from steady Amber to blinking Green.

2. Present cards to be enrolled to the reader, one at a time. When a card is presented a 60 
second timer begins. The next card must be presented within 60 seconds or Card Learn 
Mode will timeout and automatically end.
01869-001 June 1999
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3. When a card is accepted the following things happen (see Figure 3-1).

• the reader beeps once and its LED flashes Red once
• the card's number is recorded in the first empty slot beginning at the row in the 

cardholder spreadsheet where the cursor is (i.e. if the cursor is on a cell in row 1, card 
numbers are recorded in the first empty slot beginning on row 1 – if the cursor is on a cell 
in row 42, card numbers are recorded in the first empty slot beginning on row 42)

• the row to which the card has been assigned is tagged as a NEW entry and the row's color 
switches to Green

Figure 3-1 – Learning a Card

4. When a card is not accepted the following things happen.

• the reader beeps once and its LED flashes Red once
• an error message appears explaining why the card is not accepted

5. If a card is presented after Learn Mode has timed out the following window appears.

Figure 3-2 – Card Learn Mode Timeout

Stop Learn Mode

1. To stop learn Mode once all cards have been presented, click on the  button or use 
the System → Stop Learn Mode pull-down menu command.

2. When the reader exits learn mode the following things happen.

• the reader beeps twice and its LED changes from blinking Green back to steady Amber
June 1999 01869-001
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Entering Cardholder Data
Cardholder data can now be entered into the spreadsheet's data fields for each card taught to 
the cardholder database file. Simply enter cardholder information into the appropriate cells of 
the spreadsheet. The spreadsheet has the following data fields (see Figure 3-1).

STAT – displays the status of a given row in the spreadsheet. This field is not editable. The 
status remains on screen until the cardholder file is saved at which time all status values are 
cleared. There are three status values.

NEW – displayed whenever a card is learned by the system
MOD – displayed whenever the data for a card has been modified 
DEL – displayed whenever a card has been identified for deletion

CARD SLOT – identifies the slot number for a card in the spreadsheet. This field is not 
editable. There are 500 slots possible in the IntelliProx so this number is between 1 and 500.

LAST NAME – displays the last name of the cardholder for a card/slot in the spreadsheet. 
Enter the name or edit this field as needed.

FIRST NAME – displays the first name of the cardholder for a card/slot in the spreadsheet. 
Enter the name or edit this field as needed.

CARD NUMBER – displays the identification number embedded in the card for a card 
learned by the spreadsheet. The reader reads this number from the card and enters it into the 
cardholder spreadsheet. This field is not editable.

MEMO1 TO 4 – there are four Cardholder Memo fields. You decide what kind of information 
should go into these fields. Some possibilities are a cardholders' address, telephone number, 
department, or employee number. Enter information or edit these fields as required.

As an example, cardholder information for the first 10 Presidents of the United States has 
been entered. The resulting cardholder information should look similar to Figure 3-3.

Figure 3-3 – Cardholder Spreadsheet Data Fields
01869-001 June 1999
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Saving a File for the First Time
Use the Save As command to save cardholder spreadsheet data to a file on your computer 
system.

1. Click on the File → Save As pull-down menu command. The following window appears.

Figure 3-4 – Saving a New File

2. Click in the File name field and type the name for the file to which all this cardholder 
data should be saved. The name should be descriptive of the type of cardholders in the 
file, but the file name must be 8 characters or less. In this example, the file name pres.dbf 
is used.

3. Click on the  button and all data within the cardholder spreadsheet is then saved 
in its file.

Download the Data File to an IntelliProx Unit
Once the data file is created it can be sent to an IntelliProx unit. The IntelliProx must be 
connected to the host computer with the D-Lite program using the instructions provided in the 
IntelliProx SM-2000 Quick Start Guide (document P/N 01830-003). Use the Download Cards 
command to download the card file.

1. Click on the  button or use the System → Download Cards pull-down menu 
command. 

2. Before downloading data the D-Lite program compares the IntelliProx PIN stored in the 
IntelliProx with the IntelliProx PIN recognized by the D-Lite program. Both PINs must 
match or the download is halted. (Please refer to the Set the PINs section earlier in this 
document for information regarding PC and IntelliProx Unit PINs.)

3. Once the download command is begun, the reader's LED goes out (to indicate the 
IntelliProx is in data transfer mode), and the card file is downloaded from the spreadsheet 
to the IntelliProx. A communication progress window displays the data transfer progress 
(see Figure 3-5).
June 1999 01869-001
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Figure 3-5 – Communication Progress Window

4. When the download is complete a download status box is displayed summarizing what 
information was downloaded (see Figure 3-6).

Figure 3-6 – Download Status

5. After a 60 second delay, the reader beeps twice, its LED flashes Green and then returns to 
normal operation with the LED at steady Amber.

6. If a valid card is presented during the delay, the following things happen.

• the IntelliProx process the card
• the door is unlocked
• the IntelliProx returns to the delay state until the 60 seconds times out

7. If an invalid card is presented during the delay, the following things happen.

• the reader beeps and flashes its Red LED
• the IntelliProx stays in the delay state until the 60 seconds times out

NOTE: A download overwrites whatever data is in the IntelliProx. The original data in the 
IntelliProx is not recoverable once a download starts.

Now that the cardholder data file has been downloaded, the IntelliProx unit is ready for use.
01869-001 June 1999
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Open and Edit a Stored Database File, Save the File, and Download the File to an 
IntelliProx

The instructions in this section demonstrate how to open an existing cardholder database file, 
how to edit data in that file, how to save that data, how to save that data under a different file 
name, and how to download the file for use by an IntelliProx unit. This is done with the 
following steps.

• open an existing cardholder data base file
• edit a spreadsheet cell
• delete a cardholder
• undelete a cardholder
• sort cardholder data
• use block mode commands
• save the cardholder database file
• save the cardholder database file under a new name
• download the cardholder database file to an IntelliProx unit

Open an Existing Database File
Use the Open a Card File command to open an existing cardholder database file.

1. Click on the  button or use the File → Open pull-down menu command. The 
following window appears.

Figure 4-1 – Open an Existing File

2. To open an existing cardholder file, select the file from the list displayed under the “File 
name:” box. Use the scroll bar on the right side of the box to scroll through all the 

available files and click on the desired file. Then click on the  to load the card 
file. All data in the cardholder file is entered into the program spreadsheet.

Editing Cardholder Data
In addition to editing data within individual spreadsheet cells (for example, Name or Memo 
fields), you can edit the cardholder database by deleting and undeleting cardholders, sorting 
cardholder data, and block copying cardholder data from one spreadsheet cell to a number of 
cells.

Editing a Spreadsheet Cell
To edit a spreadsheet cell, simply click in the desired cell and enter the new information. The 
new information overwrites the existing information. To exit a cell you are editing by 
mistake, press the ESC key. The original information is restored to the cell.
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Deleting a Cardholder
Deleting a cardholder removes that cardholder's information from the spreadsheet, freeing that 
card slot for use by another cardholder. Perform the following steps to delete a cardholder.

1. Click on any spreadsheet cell for the cardholder to be deleted (see Figure 4-2).

Figure 4-2 – Selecting a Cardholder for Deletion

2. Click on the  button or use the Edit → Delete pull-down menu command. The 
selected cardholder is marked for deletion (see Figure 4-3).

Figure 4-3 – Cardholder Marked for Deletion

3. Click on the  button or use the File → Save pull-down menu command. The 
information for the selected cardholder is removed from the spreadsheet and the card slot 
is free for use by a new cardholder (see Figure 4-4).
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Figure 4-4 – Deleted Cardholder

NOTE: Once the cardholder file is saved, the deleted cardholder is permanently removed 
from the cardholder file and the cardholder's data cannot be recovered. However, the card is 
not recognized as deleted until the cardholder file is downloaded to the IntelliProx unit. 
Instructions for downloading the cardholder file to the IntelliProx unit are provided in the 
Download the Data File to an IntelliProx Unit section later in this Users Guide.

Undeleting a Cardholder
Undeleting a cardholder restores that cardholder's information to the spreadsheet. This can 
only be done if the cardholder selected for deletion has not been saved making the deletion 
permanent (see Figure 4-3 versus Figure 4-4). Perform the following steps to undelete a 
cardholder.

1. Click on any spreadsheet cell for the cardholder to be undeleted (see Figure 4-3).

2. Click on the  button or use the Edit → Undelete pull-down menu command. The 
selected cardholder is restored to the spreadsheet (see Figure 4-5).

Figure 4-5 – Undeleted Cardholder
01869-001 June 1999
Revision 1.0 Page 23



D-Lite™ Users Guide Keri Systems, Inc.
Sorting Cardholder Data
Use the Sort the Cardholder Data command to reorganize the data in your spreadsheet. 
Perform the following steps to sort cardholder data.

1. Click on the heading at the top of a column by which you want to sort data (see Figure 4-
6).

Figure 4-6 – Cardholder Data Before Sorting

2. Now click on the  button or use the Edit → Sort pull-down menu command. The 
data in the spreadsheet is sorted in ascending order (lowest to highest number or A to Z) 
based on the column you selected. It is then displayed in the D-Lite window (see Figure 
4-7).

Figure 4-7 – Cardholder Data After Sorting
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Block Command Mode
Use the Select a Block of Data command to perform the same action on multiple rows in the 
data base. Perform the following steps to perform block data commands.

1. To select a block of data, click on the  button or use the Edit → Block pull-down 

menu command. The  flag turns on to let you know that block mode is 
enabled.

2. Click on any spreadsheet cell in the first row to be selected (see Figure 4-8).

Figure 4-8 – Select a Row for Block Mode Command

3. There are three ways to select multiple rows (see Figure 4-9).

• Hold down the Shift key and click on any cell in the last row to be selected. The selected 
rows and all rows in between are highlighted.

• Click on a cell in the first row to be selected and drag the mouse down to a cell in the last 
row to be selected. The selected rows and all rows in between are highlighted.

• Hold down the Ctrl key and click on a cell in any row. The selected rows are highlighted 
(this method is best used when the rows to be selected are not in consecutive order).
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Figure 4-9 – Multiple Rows Selected for Block Mode Command

4. Now click on the action you wish to perform on all these rows. The action is performed 

and the  flag turns off to let you know that block mode is disabled. For 
example, click on the delete a card slot row command and the block selected rows are 
marked for deletion (see Figure 4-10).

Figure 4-10 – Block Mode Command Performed

Saving a File
Use the Save command to save the cardholder spreadsheet to a cardholder data file on your 
computer system. Perform the following steps to save a cardholder data file.

1. Click on the  button or use the File → Save pull-down menu command. The 
spreadsheet data information is immediately saved to the file name listed in the 

 field of the D-Lite screen.
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Saving an Existing File Under a New Name
Use the Save As command to save a cardholder spreadsheet to a new cardholder data file on 
your computer system. Typically, this is done when a cardholder data file can be applied to 
two or more IntelliProx units. An original cardholder data file is created and saved, and then 
the same data is saved to another file.

1. Use the File → Save As pull-down menu command. The following window appears.

Figure 4-11 – Saving a File Under a New Name

2. Click in the File name field and type the name for the file to which this cardholder data 
should be saved. The name should be descriptive of the type of cardholders in the file, but 
the file name must be 8 characters or less. In this example, the file name pres.dbf is used.

3. Click on the  button and all data within the cardholder spreadsheet is then saved 
in its file.

Download the Data File to an IntelliProx Unit
Once the data file is created it can be sent to an IntelliProx unit. The IntelliProx must be 
connected to the host computer with the D-Lite program using the instructions provided in the 
IntelliProx SM-2000 Quick Start Guide (document P/N 01830-003). Use the Download Cards 
command to download the card file.

1. Click on the  button or use the System → Download Cards pull-down menu 
command.

2. Before downloading data the D-Lite program compares the IntelliProx PIN stored in the 
IntelliProx with the IntelliProx PIN recognized by the D-Lite program. Both PINs must 
match or the download is halted. (Please refer to the Set the PINs section earlier in this 
document for information regarding PC and IntelliProx Unit PINs.)

3. Once the download command is begun, the reader's LED goes out (to indicate the 
IntelliProx is in data transfer mode), and the card file is downloaded from the spreadsheet 
to the IntelliProx. A communication progress window displays the data transfer progress 
(see Figure 4-12).
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Figure 4-12 – Communication Progress Window

4. When the download is complete a download status box is displayed summarizing what 
information was downloaded.

Figure 4-13 – Download Status

5. After a 60 second delay, the reader beeps twice, its LED flashes Green and then returns to 
normal operation with the LED at steady Amber.

6. If a valid card is presented during the delay, the following things happen.

• the IntelliProx process the card
• the door is unlocked
• the IntelliProx returns to the delay state until the 60 seconds times out

7. If an invalid card is presented during the delay, the following things happen.

• the reader beeps and flashes its Red LED
• the IntelliProx stays in the delay state until the 60 seconds times out

NOTE: A download overwrites whatever data is in the IntelliProx. The original data in the 
IntelliProx is not recoverable once a download starts.
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Upload an Existing IntelliProx Database to the D-Lite Program and Save the 
Information to a New Cardholder File.

If an IntelliProx unit is already programmed with a cardholder database, that database can be 
uploaded to the D-Lite program. Once uploaded, cardholder data can be added to the database 
and the database file can be saved to a new cardholder data file on the computer system.

Uploading the Database
Perform the following steps to upload the cardholder database from the IntelliProx.

1. Click on the  button or use the System → Upload New Cards pull-down menu 
command.

2. Before uploading data the D-Lite program compares the IntelliProx PIN stored in the 
IntelliProx with the IntelliProx PIN recognized by the D-Lite program. Both PINs must 
match or the upload is halted. (Please refer to the Set the PINs section earlier in this 
document for information regarding PC and IntelliProx Unit PINs.)

3. Once the upload command is begun, the reader's LED goes out (to indicate the 
IntelliProx is in data transfer mode), and the card file is uploaded from the IntelliProx to 
the spreadsheet. During the upload process the following upload progress window 
appears.

Figure 5-1 – Communication Progress Window

4. When the upload is complete the following upload summary window appears.

Figure 5-2 – Upload Summary

When the upload is complete all information uploaded is displayed in the spreadsheet (see 
Figure 5-3).
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Figure 5-3 – Uploaded IntelliProx Cardholder Database

Editing a Spreadsheet Cell
To edit a spreadsheet cell, simply click in the desired cell and enter the new information. The 
new information overwrites the existing information. To exit a cell you are editing by 
mistake, press the ESC key. The original information is restored to the cell.

Saving to a New Cardholder File
Use the Save As command to save the uploaded cardholder data to a new cardholder data file 
on your computer system.

1. Use the File → Save As pull-down menu command. The following window appears.

Figure 5-4 – Saving a File Under a New Name

2. Click in the File name field and type the name for the file to which this cardholder data 
should be saved. The name should be descriptive of the type of cardholders in the file, but 
the file name must be 8 characters or less. In this example, the file name pres.dbf is used.

3. Click on the  button and all data within the cardholder spreadsheet is then saved 
in its file.
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Merge an Existing Cardholder Database File with an Uploaded IntelliProx Database
In some cases you may want to merge a cardholder file saved on the computer with a 
cardholder database programmed into an IntelliProx unit. Perform the following steps to 
merge the two cardholder databases.

Open an Existing Cardholder Database File
Use the Open a Card File command to open an existing cardholder database file.

1. Click on the  button or use the File → Open pull-down menu command. The 
following window appears.

Figure 6-1 – Open an Existing File

2. To open an existing cardholder file, select the file from the list displayed under the “File 
name:” box. Use the scroll bar on the right side of the box to scroll through all the 

available files and click on the desired file. Then click on the  to load the card 
file. All data in the cardholder file is entered into the program spreadsheet.

Merge the IntelliProx File

1. Click on the  button or use the System → Upload Merge Cards pull-down menu 
command.

2.  Before merging data the D-Lite program compares the IntelliProx PIN stored in the 
IntelliProx with the IntelliProx PIN recognized by the D-Lite program. Both PINs must 
match or the download is halted. (Please refer to the Set the PINs section earlier in this 
document for information regarding PC and IntelliProx Unit PINs.)

3. Before beginning the merge, since a merge modifies the contents of the spreadsheet in the 
D-Lite program, one last warning box is displayed.

Figure 6-2 – Merge Warning Window

4. Click on the  button to start the merge.
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5. Once the merge is begun, the reader's LED goes out (to indicate the IntelliProx is in data 
transfer mode), and the card file is read from the IntelliProx to the spreadsheet. A 
communication progress window displays the data transfer progress (Figure 6-3).

Figure 6-3 – Communication Progress Window

6. Data between the card file and the spreadsheet is examined row by row. Depending upon 
what the program finds, there are four possible actions.

• The card and slot numbers are identical indicating the row is for an existing cardholder. 
There is no change to the data in the spreadsheet.

• The card and slot numbers are in the card file, but not in the spreadsheet indicating this is 
a new card/slot entry. It is added to the spreadsheet, the row is highlighted in GREEN and 
“NEW” is displayed in the STAT column.

• The card and slot numbers are not in the card file, but are in the spreadsheet indicating 
this card has been deleted from the IntelliProx. The row is highlighted in RED and 
“DEL” is displayed in the STAT column.

• The card and slot numbers from the card file do not match the card and slot numbers in 
the spreadsheet indicating a change has been made to a card/slot. The information that is 
provided by the IntelliProx’s card file takes precedence over the information that is in the 
spreadsheet. The IntelliProx information overwrites the card file information.

7. After a 60 second delay, the reader beeps twice, its LED flashes Green and then returns to 
normal operation with the LED at steady Amber.

8. If a valid card is presented during the delay, the following things happen.

• the IntelliProx process the card
• the door is unlocked
• the IntelliProx returns to the delay state until the 60 seconds times out

9. If an invalid card is presented during the delay, the following things happen.

• the reader beeps and flashes its Red LED
• the IntelliProx stays in the delay state until the 60 seconds times out

10. When the merge is complete a merge results box is displayed.
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Figure 6-4 – Merge Summary

11. Click on the  button and you can now enter new data or edit existing data in the 
spreadsheet.

Saving the Merged Cardholder Spreadsheet
Use the Save command to save the merged cardholder spreadsheet to the original cardholder 
data file or use the Save As command to save the merged cardholder spreadsheet to a new 
cardholder data file.

Saving the Merged File to the Original Cardholder Data File
Perform the following steps to save the cardholder data file to the original file.

1. Click on the  button or use the File → Save pull-down menu command. The 
spreadsheet data information is immediately saved to the file name listed in the 

 field of the D-Lite screen.

Saving the Merged File Under a New File Name
Perform the following steps to save the cardholder data file under a new file name.

1. Use the File → Save As pull-down menu command. The following window appears.

Figure 6-5 – Saving a File Under a New Name

2. Click in the File name field and type the name for the file to which this cardholder data 
should be saved. The name should be descriptive of the type of cardholders in the file, but 
the file name must be 8 characters or less. In this example, the file name pres.dbf is used.

3. Click on the  button and all data within the cardholder spreadsheet is then saved 
in its file.
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Other Features
There are a number of other features available with the D-Lite program. These features make 
it easier to use the program, print cardholder information, and manually control the door 
associated with an IntelliProx unit.

Resizing Columns
If a column is too narrow to display all the data in the column it can be resized by dragging 
the column boundary to the desired size. While within the cells of the spreadsheet, the mouse 
cursor looks like a small cross: . When the mouse cursor is over the column header row, it 
will change from a  to a  whenever the cursor hits a resizeable column boundary.

1. Locate the right boundary for the column to resize. The mouse cursor changes to .
2. Click, hold, and drag the mouse toward the middle of the column to make the column 

smaller and away from the middle of the column to make the column larger.
3. Release the mouse button and the new column size is set.

NOTE: If reducing the column size truncates the column title, simply close and reopen the 
program and the column title row will resize itself to accommodate the column titles.

Online Help

Online help is built into the D-Lite program. To access online help, click on the  button 
or click on Help → Contents to open the online help window. Once in online help, simply 
"point and click" on the item about which you have a question. If the item is nested under a 
pull-down menu, click on the menu item and follow your way down the menu tree until you 
locate the item. Once you’ve found the item, click on it and a brief description appears. When 
you are finished reviewing the help information, click on the  box in the upper right corner 
of the help window to close the window.

NOTE: When using online help, you may consider resizing the D-Lite window to take up half 
of the computer screen and then resizing the online help window to take up the other half of 
the computer screen. This allows you to jump back and forth between the program and the 
online help, tracking down information for the desired task.

Locating the Software Revision
The D-Lite software revision is stored in the program. Perform the following steps to retrieve 
the software revision.

1. Click on the Help → About pull-down menu option. The following window appears.
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Figure 7-1 – Locating the Software Revision

2. After viewing the software revision, click on the  button to close the window.

Printing a Cardholder Database File

Printer Setup
Use the Printer Setup command to configure the printer. The printer Setup command calls up 
the Windows™ operating system printer configuration dialog box for the printer selected as 
the Windows™ default printer. For information on how to set the printer configuration 
parameters click on the Help → Using Help pull-down menu option to access the help files 
provided by the Windows™ operating system program.

NOTE: Although the printer setup window gives you the option to select a different printer, 
the D-Lite program will only print to the printer designated as the Windows default printer.

Print the Cardholder File
Use the Print command to print a hard copy of the cardholder file on display.

1. To print, click on the  button or use the File → Print pull-down menu command. The 
following window appears.

Figure 7-2 – Print in Progress Window

2. Click on the  button to stop the print job. Otherwise, the Print Progress window 
closes when the print job is complete.

NOTE: The cardholder spreadsheet consists of 500 card slots and all the associated data. For 
a printer configured to print standard letter size sheets in landscape mode, this can take 
between 15 and 20 pages.
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Unit Status
Use the Get Unit Status command to retrieve status information from the IntelliProx unit.

1. Click on the System → Get Unit Status pull-down menu command.
2. Before requesting unit status the D-Lite program compares the IntelliProx PIN stored in 

the IntelliProx with the IntelliProx PIN recognized by the D-Lite program. Both PINs 
must match or the download is halted. (Please refer to the Set the PINs section earlier in 
this document for information regarding PC and IntelliProx Unit PINs.)

3. If D-Lite can communicate with the IntelliProx unit the following window appears.

Figure 7-3 – Unit Status Window

The Unit Status window has three fields.

• The Rev = X field provides the firmware revision of the IntelliProx unit.
• The COMerr = # field provides the number of COM port communication errors that have 

occurred since the last time the IntelliProx unit was reset.
• The EEPerr = # field provides the number of EEPROM errors that have occurred since 

the last time the IntelliProx unit was reset.

4. When the status command is sent to the IntelliProx the reader's LED goes out indicating 
the IntelliProx is in data transfer mode.

5. After a 60 second delay, the reader beeps twice, its LED flashes Green and then returns to 
normal operation with the LED at steady Amber.

6. If a valid card is presented during the delay, the following things happen.

• the IntelliProx process the card
• the door is unlocked
• the IntelliProx returns to the delay state until the 60 seconds times out

7. If an invalid card is presented during the delay, the following things happen.

• the reader beeps and flashes its Red LED
• the IntelliProx stays in the delay state until the 60 seconds times out

Unit Commands
Use this command to immediately lock or unlock the door. This command also allows you to 
change the IntelliProx unit's PIN or change the PC's PIN, but information for changing these 
PIN values is found in the Set the PINs section earlier in this Users Guide.

1. Click on the  button or use the System → Unit Commands pull-down menu. The 
following window appears.
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Figure 7-4 – Unit Commands Window

Lock the Door
The Lock command allows you to immediately lock the door attached to the IntelliProx unit.

1. Click on the  button, the door is immediately locked, the reader's LED flashes 
Red to indicate the door is locked and then returns to steady Amber, and the following 
window appears.

Figure 7-5 – Locked Door Acknowledgment Window

2. Click on the  button to close the window.
3. The lock command places the IntelliProx into data transfer mode. After a 60 second 

delay, the reader beeps twice, its LED flashes Green and then returns to normal operation 
with the LED at steady Amber.

4. If a valid card is presented during the delay, the following things happen.

• the IntelliProx process the card
• the door is unlocked
• the IntelliProx returns to the delay state until the 60 seconds times out

5. If an invalid card is presented during the delay, the following things happen.

• the reader beeps and flashes its Red LED
• the IntelliProx stays in the delay state until the 60 seconds times out
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Unlock the Door
The Unlock command allows you to immediately unlock the door attached to the IntelliProx 
unit.

1. Click on the  button, the door is immediately unlocked and the reader's LED 
changes to Green and stays Green to indicate the door is unlocked. The following 
window appears.

Figure 7-6 – Unlocked Door Acknowledgment Window

2. Click on the  button to close the window.

Exit the Program
You can exit the D-Lite program in two ways.

1. Click on the File → Exit pull-down menu option.
2. Click on the  box in the upper right corner of the D-Lite window.
3. If there is an open cardholder database displayed in the spreadsheet with unsaved 

changes, the following window appears.

Figure 7-7 – Save Data Before Closing D-Lite Window
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Troubleshooting
Since all communication between D-Lite and the host computer is done through the host 
computer's COM port, D-Lite cannot work if the host computer's COM port is not working 
correctly. Keri Systems cannot be held responsible for host computer COM port or hardware 
problems. Here is a basic communication test that you can perform to check the quality of the 
serial communication connection between the IntelliProx unit and the host computer/D-Lite 
software.

1. Verify the IntelliProx unit is powered on and connected to the appropriate COM port on 
the host computer.

2. Verify the COM port to which the IntelliProx unit is connected is the COM port set in the 
D-Lite program’s configuration window (refer to the Set the COM Port section earlier in 
this Users Guide).

3. Click on the  button or use the System → Unit Commands pull-down menu. The 
following window appears.

Figure 8-1 – Unit Commands Window

4. Click on the  button. Depending upon the quality of the connection between the 
IntelliProx and the host computer, one of four responses will be seen at the IntelliProx’s 
reader.

Good Connection
1. The reader beeps once, the reader's LED flashes Red to indicate the door is locked and 

then returns to steady Amber, and the following window appears.

Figure 8-2 – Locked Door Acknowledgment Window

2. Click on the  button to close the window.

This verifies that good communication exists between the IntelliProx and the host computer.
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Wrong PIN
1. The reader's LED turns off for 10 seconds. The reader then beeps once and the LED 

flashes Red four times then returns to steady Amber.

This indicates that communication exists between the IntelliProx and the host computer but 
there is an IntelliProx Unit PIN or PC PIN mismatch between the IntelliProx and the D-Lite 
program. Refer to the Set the PINs section earlier in this Users Guide to reset the IntelliProx 
Unit PIN or PC PIN.

Poor Connection
1. The reader's LED turns off for 10 seconds. The reader then beeps once and the LED 

flashes Green twice then returns to steady Amber.

This indicates that poor communication exists between the IntelliProx and the host computer. 
Communication is being corrupted by electro-magnetic interference, excessive cable length, 
or a poor connection at either the IntelliProx or the host computer.

No Connection
1. There is no response from the IntelliProx’s reader within 10 seconds of sending the Lock 

command.

This indicates there is no connection between the IntelliProx and the host computer/D-Lite 
program. Check the following items and then retry the Lock command.

• verify the COM port number used by the host computer
• verify the D-Lite program is configured to use that COM port (refer to the Set the COM 

Port section earlier in this Users Guide)
• verify the communication cable is wired correctly (refer to the IntelliProx Quick Start 

Guide – P/N 01830-003 – found in the \docs folder on the D-Lite CD-ROM)
• verify there are no shorts or opens in the communication cable
• verify the communication cable is connected to the correct COM port on the back of the 

host computer
• verify the communication cable is connected to the IntelliProx correctly (refer to the 

IntelliProx Quick Start Guide – P/N 01830-003 – found in the \docs folder on the D-Lite 
CD-ROM)

If everything in the above list appears correct, run the COMTEST provided with the D-Lite 
software package. The COMTEST program is a simple program. It is designed to send a 
string of characters out the host computer's COM port output and see if they are received back 
at the host computer's COM port input. It is not designed to determine if the COM port has 
more serious problems such as conflicts with other devices on the host computer. For these 
types of problems, troubleshooting by a computer technician is required. Instructions for 
using the COMTEST program are provided in the COMTEST Quick Start Guide (P/N 01845-
001) found in the \docs folder on the D-Lite CD-ROM.
June 1999 01869-001
Page 42 Revision 1.0



Keri Systems, Inc. D-Lite™ Users Guide
Index
C

Comtest, 5
Create a New File, 15

D
Download a Data File to an IntelliProx, 18, 27

E
Editing Cardholder Data, 21

Block Command Mode, 25
Delete a Cardholder, 22
Edit a Cell, 21, 30
Sort Cardholder Data, 24
Undelete a Cardholder, 23

Enter Cardholder Data, 17
Exit the Program, 39

L
Learn Card Mode, 15

Start Learn, 15
Stop Learn, 16

Logon, 9
M

Managing Databases, 15
Merge an IntelliProx File, 31

O
Online Help, 35
Open an Existing File, 21, 31

P
PC System Requirements, 5
Printing a File, 36

Printer Setup, 36
Program Configuration, 10

COM Port, 12
Password, 11
Set the PINs, 12

IntelliProx PIN, 14
PC PIN, 13
Send the PC PIN to the IntelliProx, 14

Spreadsheet Font, 10
R

Resizing Columns, 35
01869-001 June 1999
Revision 1.0 Page 43



D-Lite™ Users Guide Keri Systems, Inc.
S
Saving a File, 26
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