DoorsNXT Remote Port Change

Reference Document

The DoorsNXT Server and Database use TCP Ports to communicate. It is possible that another application may be using
the same ports which will prevent the DoorsNXT Server from functioning properly. The following instructions explain
how how to change the TCP Ports used by Doors NXT for proper communication.

Section 1 - DoorsNXT Server and Client On The Same PC
Section 2 - DoorsNXT Server and Client On Different PCs

Section 3 - Contact Keri Systems

1.0
1.1

DoorsNXT Server and Client On The Same PC

Stop the DoorsNXTSvr and Firebird Server services

1. To stop the DoorsNXTSvr and Firebird Server services, click on Windows Start and select Control Panel.
2. Double-click on Administrative Tools.
3. Double-click on Services.

4. Locate and click on Firebird Server so that it is highlighted.

"% Services
File  Action View Help
£l @

Firebird Server - DefaultInstance

Stop the service
Restart the service

Description:
Firebird Database Server -
www. firebirdsgl.org

| A

MName | Description ‘ Status ‘ Startup Type ‘ Log On As

%Distributed Transac... Coordinate... Manual Metwork S,
%DNS Client Resolves a...  Started Aukomatic Metwork 5.
%DoorsNxTSvr Started Autarnatic Local Systemn
%Errnr Reparting Ser...  Allaws erra...  Started Autarnatic Lacal Systemn
%aTrust Antivirus Job,., Schedules ... Started Autarnatic Local Systemn
%ETFUSt Antivirus Re...  Provides re... Started Automatic Local Systemn
%ETrust Antivirus RP... Listens for ... Started Automatic Local System
%Event Log Enables ev... Started Autarnatic Local Systern
%Event Log Watch EwentLog ... Started Aukomatic Local System
%Fast User Switching.., Provides m... Manual Local Systemn
2 Firebird ... Firebird Da... Aukarnakic Lo i
%FLEXnet Licensing S... This servic,.,  Started Manual Local Systemn
%Gﬂngla Updater Ser... Started Autarnatic Lacal Systemn
%Heln and Support Enables He... Started Autarnatic Local Systemn

\ Extended A Standard

Figure 1: Services Window

5. Click on “Stop the service.” A window appears to confirm that the DoorsNXTSvr is to be stopped as well. Click on

the “Yes” button.
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1.2 Modify System Services
1. Using Windows Explorer, locate the Windows\system32\drivers\etc folder.
2. Right click on “services” and select open.

% cic

File  Edit WView Favorites Tools Help

@Eack A > | I? /ITI\J Search ‘“F" Folders

3 @ X") (-

-5

Address ‘l’f} CHWINDOW S system3zdriversietc

v|GU

Folders E Mame

123 assembly -~ husts
1) Config 1 Imhosts
@ Connection Wizard networks
15 Crystal protacol

s [services 1
@ Cursors

1) Debug

Downloaded Program File:
12 Driver Cache =

13 ehome:

ia Fonts
153 Farms
13 Help
S ier
1= ime

2

Open

Size  Type
1KE File
4KE  SAMFile
1KE File
LKE File
7KE File
i Scan for wruses[ !
3 WinZip >
Send To 3
Cut
Copy

Create Shartout
Delete
Rename

Date Modified

FI27 12007 5:00 AM
72712007 5:00 AM
7{272007 5:00 AM
Fi2712007 5:00 AM
7(27{2007 5:00 AM

Properties

Figure 2: Windows Explorer Open Services File

3. A window appears asking what program to use to open the file. Choose the “Select the program from a list” option

and click on OK.

4. From the list select Notepad. Remove the check from the option to “Always use the selected program to open this
kind of file” and click on OK.

Open With X

‘] Choose the program you wart: to use to open this file:
File:  Firebird. conf

Programs

€3 Fullshot 9.5

(& Internet Explorer

1 unes

&2 Mergeolf

(€] Micrasoft Excel For Windows

(A CuickTime Flaver

>

Type a description thak you want ko us for this kind of file:

[[] always use the selected program to open this kind of file

for the appropriate program on the eh,

Browse...

TF the program you want is not in the list or on your computer, you can look

Figure 3: Select Program

5. In Notepad, click on Edit > Find. Enter “gds_db” and click on the “Find Next” button.
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1l Al pad =
s
| [_EindNest | fefined by IANA

Fo

# OUp @ Down R

#<s [H=comment=]

#

echo Thep

echo Thudp

discard Qftcp  sink null

discard Qfudp  sink null

Systat 11tcp  users #Active Users

Systat 11tcp  users #Active Users

daytime 13fcp

daytime 13/udp

qotd 17itcp  quote #Quote of the day

qotd 17/udp  quote #Quote of the day

chargen 19ftcp  thytst source #Character generator

chargen 19/udp  thytst source #Character generator

ftp-data 20ftcp #FTP, data

ftp 21ftep #FTF . control

telnet 23ftep v

Figure 4: Find “RemoteServicePort”
6. The following line should appear:
gds db 3050/tcp #InterBase or Firebird server

NOTE: The wording of the #comment will vary depending on whether the entry was put there by InterBase or an old
version of Firebird. If that line is not listed, it must be added to the bottom of the list (in the #comment, remove the “or
Firebird” portion).

7. Next, add a new line with an entry for the Firebird service port exclusively, using a different port and service name
(the port number may be any valid port of your choosing):

fb_db 3051/tcp #IFirebird server

8. Click on File > Save to save the changes.
9. Reboot the PC for the changes to take effect.
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1.3 Change the Remote Service Name

1. Using Windows Explorer, locate the *“...\DoorsNXT\OtherFiles\firebird.conf™ file.
2. Right click on firebird.conf and select open.

% OtherFiles r:] [E”‘S__(

J
r

File Edit View Favorites Tools  Help 4
e Back ~ () l? /_\J Search ‘[F“ Folders |'$ j x n v
address |1i'| C:\DoorsNXT\OtherFiles "| e
Folders X Mame Size | Type Date Modified
@ Desktop ~| | Cbin File Folder 5/19/2008 2:59 PM
(53 My Docurnents || it File Falder 5/19(2005 2:59 PM
= My Computer [C3)UDF File Falder 5/19(2005 2:59 PM
g 314 Floppy (4:) aliases,conf 1KB COMF File 5/19/2003 2:59 PM
[= % Local Disk (C:) [Z] Firehird 3KE Text Document 5/20/2008 12:34 PM
25 Alkiview B4 firebird 125KB  Outlaok Item 12{7/2007 3:14 PM
3 audios bird, canf ZZKE  COMF File 5/19(2005 2:59 PM
[;fj Documents and Settings = security2, fd| m 668 KB FDE File 5/20/2008 12:34 PM
= ) DoorshsT @ Scan for viruses. .,
[ Client1 Q windin i
2 clientz Send To »
I3 Client3
I3 CurrentClisnt Cut
= |2 OtherFiles Copy
[ bin Create Sharteut
= intl Delete
I uoF Rename
15 keri w
Properties
Open

Figure 5: Windows Explorer Open Firebird.conf File

3. A window appears asking what program to use to open the file. Choose the “Select the program from a list” option
and click on OK.

4. From the list select Notepad. Remove the check from the option to “Always use the selected program to open this
kind of file” and click on OK.

Open With

- j Choose the program you want to use ko open this file:

File:  firebird.conf

Programs

@ Fulishot 9.5 ~
'_fé Internet Explorer

J; iTunes

£ Mergealf

Microsoft Excel for Windows

Microsoft Word For Windows B

Y paint
€A OuickTime Plaver b

Type a description that you want ko use For this kind of file:

[ always use the selected program ta open this kind of fils

If the program you want is not in the list or on your computer, yvou can look
for the appropriate program on the Web,

[ Ok ] [ Cancel

Figure 6: Select Program
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5. In Notepad, click on Edit > Find and enter “RemoteServiceName” (notice there are no spaces between the words).
Click on the “Find Next” button.

I firebird.conf - Notepad
File Edit Format View Help

# follow instru

# http:/fsuppol [?]
iTypej intege Find what: |HemoteServiceName | Find Mext

# Direction
#DummyPac [IMatch cass Ole ®Down
S

# TCP Protocol Settings

#

# The TCP Service name/Port number to be used for client database
# connections.

#

#1tis only necessary to change one of the entries, not both. The

# order of precendence is the (g i al=] (if anentryis
# found in the 'services ' file) then the 'RemoteServicePort'.

#

# Type: string, integer
#

#RemoteServiceName = gds_db
#RemoteServicePort = 3050

Figure 7: Find “RemoteServiceName”

6. The RemoteServiceName must be changed to match the changes made previously (gds_db needs to be replaced with
fb_db). Also, the line must be activated by removing the # symbol. The following lines:

#RemoteServiceName = gds_db
#RemoteServicePort = 3050

Should be changed so that they appear as:

RemoteServiceName = fb_db
#RemoteServicePort = 3050

7. Click on File > Save and close Notepad.
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14 Restart the DoorsNXTSvr and Firebird Server services

1. To restart the DoorsNXTSvr and Firebird Server services, click on Windows Start and select Control Panel.
2. Double-click on Administrative Tools.
3. Double-click on Services.

4. Locate and click on DoorsNXTSvr so that it is highlighted.

. Services
File Action View Help

[zl 2
1%, Services (Local)

4 Services (Local)

logonas | &

DoorsNXTSvr Mame Description Status Startup Type
%Computer Browser Mainkains a... Automatic Lacal System
Start the service 8 Cryprographic Servi... Providesth... Stated  Automatic Local System
%DCOM Server Proce,., Providesla... Started Aukomatic Lacal System
8 DHCP Client Managesn... Started  Automatic Local System
%Dismhutad Lirk Tra... Mainkains ... Started Automatic Local System
2 Distributed Transac,.. Coordinate... Marual Metwork 5
88015 Client Resolves a..,  Started  Automatic
Automatic
. Allows erro... Started Automal
%eTrust Antivirus Job,., Schedulss ... Started Aukomatic Lacal System
%ETrust Antivirus Re...  Providesre... Starked Automatic Local System
%ETl’ust Antivitus RP...  Listens Far ... Starked Automatic Local System
4 Event Log Enables ev... Started  Automatic Local System
8 Event Log Watch Eventlog... Started  Automatic Local System
%Fast User Switching... Provides m... Manual Lacal System
iﬁﬁremd Server - De... Firebird Da... Automatic Local System |

% Extended A Standard

Figure 8: Restart DoorsNXTSvr and Firebird Services

5. Click on “Start the service.” When the DoorsNXTSvr is started, the Firebird Server is automatically started.
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2.0
2.1

L=

*% Services

EBX

DoorsNXT Server and Client On Different PCs

Stop the DoorsNXTSvr and Firebird Server services

File Action View Help
[Eg] @
l@ Services (Local)

Firebird Server - DefaultInstance Mame | Description ‘ Status ‘ Startup Type ‘ Log On As | [

%Distributed Transac... Coordinate.., Manual Metwork 5.,

gﬁﬂtﬂﬂl‘aﬁie”'ce_ %DNS Client Resolves ... Started Automatic Metwork s,

SESEL e servis %DuursNXTSvr Started Aukomatic Local System

%Error Reparting Ser...  Allows erra,,,  Started Autarnatic Local Systern
Eesgiﬂtgnéab s %ETrust Antivirus Job... Schedules ... Started Automatic Local System

irebird Database Server - i N

o, firebirdsl.org %aTrust Ankivirus Re...  Provides re... Started Automatic Local System

%ETrust Antivirus RP... Listens for ... Started Autarnatic Lacal Systemn

%Event Log Enables ev... Started Autarnatic Local Systemn

%Event Log Watch Eventlog ... Started Autarnatic Lacal Systemn

%Fast User Switching.., Provides m... Manual Local System

ireb ... Firebird Da... Started Aukomatic Lo ystem

%FLEXnet Licensing 5... This servic...  Started Manual Local System

%Google Updater Ser... Started Autarnatic Local Systern
%Help and Support Enables He... Started Automatic Local System v

\ Extended A Standard

Figure 9: Services...

To stop the DoorsNXTSvr and Firebird Server services, click on Windows Start and select Control Panel.
Double-click on Administrative Tools.

Double-click on Services.

Locate and click on Firebird Server so that it is highlighted.

5. Click on “Stop the service.” A window appears to confirm that the DoorsNXTSvr is to be stopped as well. Click on

the “Yes” button.

2.2

Change the Remote Service Port
1. Using Windows Explorer, locate the .. \DoorsNXT\OtherFiles\firebird.conf” file.

2. Right click on firebird.conf and select open.

B DtherFiles

File Edit View Favorites Tools Help

1 Altiview irebird

1) audios

Open

125KB  Outlook Ikem
22KE CONF File

v
@ Back - =) l_ﬁ P ) Search [17‘ Folders | |'ep ,j; x E’ v
address |@ C:\DaorsNxT\OtherFiles M E
Folders x Name Size | Type Date Modified
Desktop ~ || [Chbin File Folder 5/19/2008 2:59 PM
uD My Documents [Eint! File Folder 5/19/2008 2;59 PM
B '3 My Computer [C3unF File Folder 5/19/2005 2:59 PM
B 34 Floppy (83 =] aliases. canf 1KE CONF Flle 5/19/2005 2:59 PM
(=) e Local Disk (C:) @ firebird 3KB Text Docurent 51202005 12:34 PM

12/7/2007 3:14 PM
5(19/2008 259 M

() Documents and Settings secur\tyzmlm 663KB FDE Fie 5{20/2008 12:34 PM
e @ 5con for viruses...
) clientt @ winZp !
1) Clientz Send To »
1) Clients o
153 CurrentClient !
= 3 OtherFies Copy
1) bin Create Shortcut
12 inkl Delete
I oF Rename
2 keri v
Properties

Figure 10: Windows Explorer

Open Firebird.conf File
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and click on OK.

kind of file” and click on OK.

Open With

- j Choose the program you want ko use to open this file:
File:  firsbird.conf

Programs

& Fulshot 9.5 A
& Tnternet Explorer

,@ iTunes

D) Mergeolf

Microsoft Excel for Windows

licrosoft Word for Windows W

lj Paint:

3 OuickTime Plaver bs
Type a description that you want ta use For this kind of file:

[ &lways use the selected program bo open this kind of file

I the program you want is not in the list or on your computer, you can laok
for the appropriate program on the Wb,

Figure 11: Select Program

5.
Click on the “Find Next” button.

I firebird.conf - Notepad
File Edit Format View Help

X

# then adjust your server OS settings appropriately. On UMK like OS's,
# modify contents of /procisysinetipvditcp_keepalive ™ OnWindows,
# follows instrutions of this article:

# httpe/fsupport microsoft. comfdefault aspx?kbid=140325

#

# Type: integer
#
#Dun L 7

Find what: |F|emoteServic:eF'ort | Find Mext
o Direction

# [IMatch cass OUp @ Down

# The t database
# connections.

#

#1tis only necessary to change one of the entries, not both. The

# order of precendence is the 'RemoteServiceMName' (if an entry is

# found in the 'services ' file) then the 'RERT g

#

# Type: string, integer

#

#RemoteServiceName = gds_db
#RemoteServicePort = 3050

<

Figure 12: Find “RemoteServicePort”

A window appears asking what program to use to open the file. Choose the “Select the program from a list” option

From the list select Notepad. Remove the check from the option to “Always use the selected program to open this

In Notepad, click on Edit > Find and enter “RemoteServicePort” (notice there are no spaces between the words).
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6. 5 lines below, enter “RemoteServicePort=3051" in a new line below the line “#RemoteServicePort=3050.”

NOTE: The new RemoteServicePort number may be any valid port that is not in use by any other programs on the PC.

B firebird.conf - Motepad
File Edit Format View Help

# TCP Protocol Settings
#

# The TCP Service name/Fort number to be used for client database
# connections
#

#Itis only necessary to change one of the entries, not both. The
# order of precendence is the 'RemoteSenviceMName' (if an entry is
# found in the 'services ' file] then the 'RemoteServicePort'.

#

# Type: string, integer

#

#RemoteSenviceMame = gds_db
#RemoteServicePart = 3050
RemoteServicePart = 3051

#

# The TCP Port Number to be used for server Event Notification
#messages. The value of 0 (Zero) means that the server will choose
# a port number randomly.

#

# Type: integer

#

RemoteALxPort = 3060

! o
Figure 13: Enter New Port
7. Click on File > Save and close Notepad.
8. Reboot the PC for the changes to take effect.
3 Restart the DoorsNXTSvr and Firebird Server services

LD =N

% Services

Fils  Action  Yisw  Heln
) 2
l@ Services (Local)

. Services (Local)

DoorsNXTSvr Mame Descripkion Status Startup Type Log On As ‘ ~
% Computer Browser  Maintains a... Automatic Local System
Start the service 8 Cryprographic Servi... Providesth.. Started  Automatic Local System
DCOM Serwer Proce... Providesla...  Starked Aukomatic Lacal System
S8 DHCP Client Managesn... Started  Automatic Local System
% Distributed Link Tra... Maintains ...  Started Aukomatic Lacal System
8 Distributed Transac...  Coordinate... Manual Metwork 5

%DNS Clignk Resolves 3., Starked Automatic Metwork,

rror Reporting Ser...  Allows erro...  Starked  Aukomatic acal System
%eTrust Antivirus Job... Schedules ... Started Aukomatic Lacal System
%ETrust Antivirus Re...  Providesre... Started Automatic Local System
%eTrust Antivirus RP... Listens for ... Started Aukomatic Lacal System
88 Event Log Enables ev... Started  Automatic Local System
%Event Log \Watch EventLlog ... Started Aukomatic Lacal System
8 Fast User Switching... Provides m. . Manual Local System
8 Firebird Server - De... Firshird Da. . Atomatic Local System

\ Extended A Standard

Figure 14: Restart DoorsNXTSvr and Firebird Services

To restart the DoorsNXTSvr and Firebird Server services, click on Windows Start and select Control Panel.
Double-click on Administrative Tools.

Double-click on Services.

Locate and click on DoorsNXTSvr so that it is highlighted.
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5. Click on “Start the service.” When the DoorsNXTSvr is started, the Firebird Server is automatically started.

6. Open up each Client and select the Connection Settings tab. After entering the password, change the Server Name to
add the port number.

For example: If the servername was “DoorsNXTServer” it needs to be changed to read “DoorsNXTServer/3051" (or
whatever port number is used). This will tell the client to communicate to the firebird server using port 3051 instead
of the default port of 3050.

3.0 Contact Keri Systems

Keri USA Keri UK, Ireland, Europe
2305 Bering Drive Unit 17
San Jose, CA 95131 Park Farm Industrial Estate
Ermine Street
Buntingford
Herts SG9 9AZ UK
Telephone: (800) 260-5265 Telephone: + 44 (0) 870 444 7234
(408) 435-8400
Fax: (408) 435-7163 Fax:+ 44 (0) 1763 274 106
Web: www.kerisys.com Web:www.kerisystems.co.uk
E-mail: sales@kerisys.com E-mail:sales@kerisystems.co.uk
techsupport@kerisys.com tech-support@kerisystems.co.uk

End of document.
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